icona-whatsapp-instagram-facebook-istock

Avete un iPhone 4? Presto dovrete dire addio a WhatsApp!

Giuseppe Tripodi E non solo WhatsApp: iPhone 4 diventerà presto obsoleto e la maggior parte delle applicazioni non saranno più compatibili.

Avremmo voluto annunciarlo in maniera più delicata, ma non ci sono molti modi per addolcire la notizia: nonostante sia ancora un dispositivo molto diffuso, iPhone 4 sarà presto uno smartphone obsoleto, che non supporterà la maggior parte delle nuove applicazioni.

Nello specifico, la segnalazione arriva parlando di WhatsApp, ma vale un po’ per tutti i nuovi software. Questo perché la nuova versione di XCode (ossia il tool per sviluppare le app iOS) rimuoverà il supporto ad iOS 7, introducendo quello per iOS 10.

LEGGI ANCHE: Le novità più importanti di iOS 10 (video)

Per questo motivo, gli sviluppatori che vorranno supportare l’ultima versione del sistema operativo (ossia tutti) non potranno pubblicare l’app anche per iOS 7 e, quindi, su iPhone 4 (il cui ultimo aggiornamento è proprio iOS 7.1.2). Il cambiamento si inizierà a sentire a partire dall’autunno, quando Apple rilascerà l’aggiornamento ufficiale ad iOS 10 per tutti i dispositivi compatibili e non riguarderà iPhone 4S e superiori (aggiornati almeno ad iOS 9).

C’è da specificare che i software interessati non spariranno da iPhone 4, ma non saranno più aggiornati. Sarà possibile installare l’ultima versione compatibile con iOS 7, ma effettivamente è solo una questione di (poco) tempo prima che le applicazioni rimuovano definitivamente il supporto.

Ad esempio, secondo quanto riferito da WABetaInfo, il suddetto WhatsApp non supporterà più iOS 7 a partire dal 1 gennaio 2017. Purtroppo, sembra che i possessori di iPhone 4 dovranno pensare di cambiare smartphone entro la fine dell’anno.

Via: WABetaInfo
  • Mattia Favali

    Ma però che rottura! Va bene che iOS 7 è ormai vecchio e anche l’iPhone 4 a la sua età, però non dare neanche più supporto alle app mi sembra esagerato…

    • peppeuz

      Non è una questione che dipende dagli sviluppatori: Apple ha rimosso il supporto ad iOS 7 nell’ultimo XCode e, ovviamente, tutti preferanno pubblicare i nuovi aggiornamenti per iOS 10 piuttosto che per iOS 7.

      In ogni caso ti capisco, iPhone 4 è uno smartphone storico!

      • Mattia Favali
      • marco

        nulla vieta di continuare a sviluppare o mantenere una versione delle app, specialmente quelle di messaggistica, utilizzando l’xcode compatibile con le api di ios7. whatsapp è usato molto in paesi sottosviluppati e in quei paesi apple ha venduto parecchi iphone datati. certo se si va a vedere che google non supporta ios7 per il suo Foto da sempre il panorama non è dei migliori per i possessori di quel telefono.